1.
Check MPIO filesets available:
lslpp -l
devices.common.IBM.mpio.rte
2. Get Hitachi Specific MPIO ODM
Updates from
Collect
MPIO Base and updates: List below current at 2 Feb 2013
https://tuf.hds.com/wiki/pub/Main/AIXODMUpdates/aix_odm_5400.zip
https://tuf.hds.com/wiki/pub/Main/AIXODMUpdates/aix_odm_5401U.zip
https://tuf.hds.com/wiki/pub/Main/AIXODMUpdates/aix_odm_5402U.zip
https://tuf.hds.com/wiki/pub/Main/AIXODMUpdates/aix_odm_5403U.zip
https://tuf.hds.com/wiki/pub/Main/AIXODMUpdates/aix_odm_5404U.zip
1) Unzip all files and move *.tar and *U to your target server in
path /usr/sys/inst.images.
2) cd /usr/sys/inst.images
3) extract tar file
tar
xvf *tar
4) inutoc .
5) Remove packages Hitachi.aix.support.rte and its dependent
package Hitachi.hacmp.support.rte which
relates to no MPIO driver ( e.g. HDLM or
PowerPath ). These are incompatible with
native MPIO driver for HDS disks. Make
sure to change remove dependent software to yes or action will fail
6) smitty install: Select
and install the software in /usr/sys/inst.images
7) check installed filesets
8) if any Hitachi disks have been detected already, remove them
with rmdev -dRl hdisk
9) Reboot server at soonest opportunity
10) Check for detected MPIO disks: "lsdev -Cc disk"
11) Check that 2 or more paths are seen to the Hitachi disk: "lspath"
12) can also check paths and disk sizes by
echo
“ No hdiskxx size mb No-paths”
p="/usr/sbin/lspath";for
i in `$p| awk ' !/Missing/ {print $2}'|sort|uniq `;do echo "$i; `getconf
DISK_SIZE /dev/$i` mb; `$p| awk ' !/Missing/ &&/'$i' / {print $2}'|wc
-l|sed 's/ //g'`" ; done|cat -n
13) Default setup of multipath is failover, reserved single path,
qdepth=2. you can check this with lsattr -EL hdisk4 for example.
14) To configure round-robin with queue depth of 8
we need to change each disk
as follows:
chdev -l hdisk4 -areserve_policy=no_reserve -a
algorithm=round_robin -a queue_depth=8
This will also have to be done for any new
disks that get added.
15) Validate that new settings are applied using lsattr -EL
hdisk
16) Thats it. You can build
your volume groups and filesystems as needed
17) you can check to ensure data is going down both fibre adapters
by running "iostat -a | grep fcs"
No comments:
Post a Comment